Turris OS 5.2.6 is released out!

Dear Turris users,

Turris OS 5.2.6 is released to all of you from the testing branch. I would like to thank anyone who tested this release. It means a lot because our new colleague prepared this release @mvasilek! :wink:

What is new in Turris OS 5.2.6?

  • OpenWrt main repository:
    • security update related to OpenSSL
    • updated kernel
  • OpenWrt packages repository:
    • @mvasilek upstreamed security updates for tar, file, apr, mc
    • updated nextdns
    • fixed https-dns-proxy, which was not available for Turris MOX

When this update will be downloaded and applied?

  • If you are using automatic updates, then yes. We suggest updating from Turris OS 5.2.4.
    This release is for Turris 1.x, Turris Omnia, Turris MOX and Turris Shield devices.
  • If you are not using automatic updates, then check reForis to approve the update.

I found some bug, what should I do?

As always, we appreciate any feedback regarding this release.


List of known bugs:

Turris HW known bugs:

  • In some cases, Turris MOX and Turris Shield are not correctly rebooted.
    You could try to remove the power supply and plug it back. We are working to have the solution with the manufacturer of SoC (Marvell). In the meantime, you can try this workaround.

Are you sure it’s released?

reForris says no updates,
console says:

root@mox:~# opkg update
Downloading https://repo.turris.cz/hbs/mox/packages/core/Packages.gz
Updated list of available packages in /var/opkg-lists/turrisos_core
Downloading https://repo.turris.cz/hbs/mox/packages/core/Packages.sig
Signature check passed.
Downloading https://repo.turris.cz/hbs/mox/packages/base/Packages.gz
Updated list of available packages in /var/opkg-lists/turrisos_base
Downloading https://repo.turris.cz/hbs/mox/packages/base/Packages.sig
Signature check passed.
Downloading https://repo.turris.cz/hbs/mox/packages/cesnet/Packages.gz
Updated list of available packages in /var/opkg-lists/turrisos_cesnet
Downloading https://repo.turris.cz/hbs/mox/packages/cesnet/Packages.sig
Signature check passed.
Downloading https://repo.turris.cz/hbs/mox/packages/luci/Packages.gz
Updated list of available packages in /var/opkg-lists/turrisos_luci
Downloading https://repo.turris.cz/hbs/mox/packages/luci/Packages.sig
Signature check passed.
Downloading https://repo.turris.cz/hbs/mox/packages/node/Packages.gz
Updated list of available packages in /var/opkg-lists/turrisos_node
Downloading https://repo.turris.cz/hbs/mox/packages/node/Packages.sig
Signature check passed.
Downloading https://repo.turris.cz/hbs/mox/packages/packages/Packages.gz
Updated list of available packages in /var/opkg-lists/turrisos_packages
Downloading https://repo.turris.cz/hbs/mox/packages/packages/Packages.sig
Signature check passed.
Downloading https://repo.turris.cz/hbs/mox/packages/routing/Packages.gz
Updated list of available packages in /var/opkg-lists/turrisos_routing
Downloading https://repo.turris.cz/hbs/mox/packages/routing/Packages.sig
Signature check passed.
Downloading https://repo.turris.cz/hbs/mox/packages/sidn/Packages.gz
Updated list of available packages in /var/opkg-lists/turrisos_sidn
Downloading https://repo.turris.cz/hbs/mox/packages/sidn/Packages.sig
Signature check passed.
Downloading https://repo.turris.cz/hbs/mox/packages/telephony/Packages.gz
Updated list of available packages in /var/opkg-lists/turrisos_telephony
Downloading https://repo.turris.cz/hbs/mox/packages/telephony/Packages.sig
Signature check passed.
Downloading https://repo.turris.cz/hbs/mox/packages/turrispackages/Packages.gz
Updated list of available packages in /var/opkg-lists/turrisos_turrispackages
Downloading https://repo.turris.cz/hbs/mox/packages/turrispackages/Packages.sig
Signature check passed.
root@mox:~# opkg list-upgradable
root@mox:~# date
Mon Aug 30 13:27:53 CEST 2021


Even Index of /hbs/mox/lists/
says 19.8. as last update

@mvasilek ping ^

Not yet. It will be. That’s why this thread is not listed anywhere. I should rather use different category until it’s out. :-/

And… now it is out! :wink:

1 Like

Just out of curiosity, is it some special MOX configs (e.g. combination of A, C, S module), or is it specific hardware revisions that are affected by the reboot bug?

1 Like

Nextcloud server does not work :slightly_frowning_face:

Hello @cefeus,

I am so sorry to hear that. There were no updates related to the Nextcloud server and its DB, which is unrelated to this release.

It would be helpful to know what exactly does not work. Otherwise, I can not help you. It will be useful to have, e.g., output related to nextcloud from the system log, which will give me more insights into the issue you are experiencing. If there isn’t anything in the system log or you don’t know what you are looking for, then screenshots, details included from diagnostics will be able to help us.

With all of this, our support department can assist you as suggested in the OP and forward it to developers or even help you straightaway, if it is related to your settings somehow.

To be honest, I think that’s the million-dollar question. I am afraid that it is not related to any combination of MOX modules and neither related to HW revisions. I can just guess that it is somehow related to SoC as silicon is not exactly all the same, but who knows. Anyway, if you have this issue and your router is under warranty, feel free to reach the support department.

I tried to reproduce it even I have basically no details of what might be wrong. Still, even after work time, at around 21:00 (GMT+2), I took Turris Omnia router, installed Nextcloud, configured admin details in Foris and voila. It works for me.

I can’t find a tag for v5.2.6 in Turris / Turris OS / Turris Build · GitLab

Fixed, sorry, this one is on me!

So this is my 3rd day of using the Omnia as my main router and I’m really starting to hate the experience so far. First all of my static leases got wiped after I turned it on, but now it’s far worse.

After the latest update (I believe it was 5.2.6) my Omnia started to bootloop.

After a while it seems to stop bootlooping, but it “stabilizes” without the WiFi LED (and no WiFi networks)

I also can’t connect automatically via Ethernet because my physical interface does not getn an IP address. If I set a manual IP address for my laptop’s Ethernet interface, I can ping Omnia but I can’t SSH into it (Connection refused)

I tried reverting to the old snapshot (2 LED reboot), but it started bootlooping after that as well.

I have no idea what to do. I’m now getting Internet from my mobile data, of which I only have 1 GB left.

Also please do tell if I should make a new thread about this.

You didn’t say how did you configure static leases as they got wiped. You edited files manually, am I right? You didn’t say how did you have your router configured. Thus I am not able to help you further. If you want to get any help, I advise you to follow this article for Getting help as I am pretty sure that it is not related to this update, which was released.

It has been a pretty long day for me, so forgive me if I left some details out.

You edited files manually, am I right?

No, everything was done either in reForis or the LuCi webUIs.

You didn’t say how did you have your router configured.

I’d very much like to dump all of the config to a text file and paste it here, but how would I do that if I can’t connect to my Omnia?

In that case as I said earlier, the support department will help you even you can not connect to your router via Ethernet and Wi-Fi. There are some other ways as we are not going to troubleshoot it here on forum.

Maybe do a factory reset, or even better, flash it with the latest medkit?