Samba USB Disk not showing in Windows 10

So I have mounted my NTFS usb drive using Writable NTFS [Old OpenWrt Wiki]

Here is how it looks in LuCi:

I have configured Samba Share:

but I don’t see this share in windows 10 at all. I’m new to samba - i tried mounting network drive in W10 using \\turris\ntfs, \\\ntfs and \\ntfs but no luck.

What am I doing wrong? Also, what is the correct address of the samba share given my configuration?

PS: I have also tried but no luck either.

Thanks for help,

Can you confirm that you have installed both of these packages?

Description of this package:
The Samba software suite is a collection of programs that implements the SMB protocol for UNIX systems, allowing you to serve files and printers to Windows, NT, OS/2 and DOS clients. This protocol is sometimes also referred to as the LanManager or Netbios protocol.

Description of this package:
Network Shares - Samba SMB/CIFS module
I guess you have this installed, because you are able to configure it through the webinterface (luCi)

If yes, could you post your smb.conf file.

How to get this.

Step 1: SSH to your Turris
Step 2: type
cat /etc/samba/smb.conf

Copy and past what you have copied in the post.

Have you installed ntfs-3g package? For NTFS formatted drives you must have this package which allowes using them under Unix systems.

There is also guide how to run NAS under Turris (in Czech language only for now, but there should be in English very soon)

It looks like I was missing smb.conf file. All I had was smb.conf.template, I have created it’s copy and now it is working … though I have followed the tutorial steps in link provided by Filip, so I’m not sure which helped.

I will do some checks now but I’m sure I’ll now be able to tweak the settings to my liking.

Thanks for help.

Oh well … to me it looks like hotplug is always enabled even when disabling it in LuCi.

The USB drive is always mounted into /tmp/run/mountd/sda1 after rebooting turris router. Why? I want to mount it into specific location using service/init script but none seem to work (probably because it is already mounted automatically?)

I can either mount it manually using command in Writable NTFS [Old OpenWrt Wiki] (which works) but creating init.d file described in Domácí NAS [Turris wiki] does not seem to do anything.

This /tmp/run/mountd/sda1 is going to be mounted automatically by “mountd”, after you disable this service you will have no more this mount point.
Automount which you show in Luci is refers to setting of service “fstab”

Thanks, that helped.

Hi @Hans_Olo, is your issues resolved? If not, run:

/etc/init.d/samba enable
/etc/init.d/samba start

Afterwards, you should be able to mount it under Windows10 using:


1 Like

@Tom that did it. I configured Samba using the web interface but a /etc/init.d/samba start was needed to kick it off. Weird

1 Like