Turris Shield - Factory Reset

Hey guys, Today I got my new Turris Shield delivered but set the wrong password and don’t remember it. How can I do a factory reset with the Turris Shield?

Best Regards

You can use the same method as for MOX: https://docs.turris.cz/hw/mox/rescue_modes/

See this video how to do it: https://www.youtube.com/watch?v=IzvUKJjsiCE

1 Like

what image do i have to flash for a factory reset?

Flashing this: https://repo.turris.cz/hbs/medkit/mox-medkit-latest.tar.gz does a reset. But Shield is greeting me with LuCI GUI …

Ok - I think this is the right one for Shield? https://repo.turris.cz/hbs/medkit/mox-medkit-contract-shield-latest.tar.gz

You should do some work on your documentation ;).

Thank you for your suggestion. We have been already working on the documentation but I have created an issue for it now: https://gitlab.nic.cz/turris/user-docs/-/issues/72

The medkit you mention is the right one.

1 Like

Ok. But then I dont understand this:

The Shield out of the box had no working LuCI. After flashing https://repo.turris.cz/hbs/medkit/mox-medkit-contract-shield-latest.tar.gz it had LuCI and Reforis …

Thanks. Worked for me.

1 Like

LuCI is not supported on Shield and it shouldn’t be there. We will look at it: https://gitlab.nic.cz/turris/turris-os-packages/-/issues/668

Just to clarify:

I have succesfully flashed https://repo.turris.cz/hbs/medkit/mox-medkit-latest.tar.gz to an empty SD-Card on the Shield.

I have not renamed the file to mox-medkit-contract-shield-latest.tar.gz.


I’m a bit stuck at the moment. I can’t configure my Turris Shield an found the threat here. I try to do a factory reset.

The following steps I’ve done:

  • using the reset button and hold it for more the 6 Seconds | did not work
  • flashing latest turris-shield medkit to a new 32 GB SD Card, insert and start | did not work

Could you maybe give some hints or advice?

Solved it! Required a few more restarts.